misterhouse insteon iolinc to garage door : lost

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

misterhouse insteon iolinc to garage door : lost

jamby
I have had several power outages in the last month and finally a PLM that had been requiring a reset after each outage died.  I already had a replacement but now after executing a "link to interface" on lights everthing is working.  But not the iolinc, attempted "link to interface" with no result.  Tried "link relay to sensor" too.  
The old system was X10 now the system is all Insteon and I can handle the lights without to much trouble but I don't understand the iolinc, iolinc door, or iolinc sensor work together.
There is code that turns on the porchlight when the garage state is "open" but nothing is working.

Snip of startup.log

11/12/16 08:48:16 AM Running: garage iolinc link relay to sensor
11/12/16 08:48:19 AM [Insteon::BaseMessage] WARN: now resending obj=$garage_iolinc; command=set_operating_flags; extra=040000000000000000000000000000 after 1 attempts.
11/12/16 08:48:22 AM Running: garage iolinc print message stats
11/12/16 08:48:22 AM [Insteon::BaseDevice] Message statistics for $garage_iolinc:
    In Corrupt %Corrpt  Dupe   %Dupe HopsLeft Max_Hops Act_Hops
 10188       1    0.0%  2894   28.4%      1.1      2.3      1.2
   Out    Fail   %Fail Retry AvgSend Avg_Hops CurrHops
   602      59    9.8%   245     1.4      1.1        2
11/12/16 08:48:22 AM [Insteon::BaseMessage] WARN: now resending obj=$garage_iolinc; command=set_operating_flags; extra=040000000000000000000000000000 after 2 attempts.
11/12/16 08:48:23 AM [Insteon::IOLinc] Acknowledged flag set for $garage_iolinc
11/12/16 08:48:23 AM [Insteon::BaseInterface] WARN! Dropped duplicate incoming message 348b5641eebf232004, from $garage_iolinc
11/12/16 08:48:24 AM [Insteon::BaseInterface] WARN: received insteon ACK/NACK message from $garage_iolinc but cannot correlate to sent message! IGNORING received message!!
11/12/16 08:49:43 AM Running: garage iolinc link relay to sensor
11/12/16 08:49:46 AM [Insteon::BaseMessage] WARN: now resending obj=$garage_iolinc; command=set_operating_flags; extra=040000000000000000000000000000 after 1 attempts.
11/12/16 08:49:47 AM [Insteon::IOLinc] Acknowledged flag set for $garage_iolinc
11/12/16 08:49:48 AM [Insteon::BaseInterface] WARN: received insteon ACK/NACK message from $garage_iolinc but cannot correlate to sent message! IGNORING received message!!

snip of insteon.mht

## new code for garage door control
INSTEON_IOLINC, 34.8B.56, garage_iolinc, Sensors
CODE, $iolinc_sensor = new Insteon::IOLinc_sensor($garage_iolinc);
CODE, $iolinc_door = new Insteon::IOLinc_door($garage_iolinc);



I am sure there is much information I am leaving out but as I don't know what anyone needs I'll wait for a question.

Thanks
Jim
Reply | Threaded
Open this post in threaded view
|

Re: misterhouse insteon iolinc to garage door : lost

jamby
Well     Some combination of attempts to link the iolinc must have finally aligned with the stars because now it working..

Last attempt messages was

11/14/16 08:47:24 AM [Insteon::AllLinkDatabase] WARN The link table for $garage_iolinc has changed.
11/14/16 08:47:24 AM [Insteon::AllLinkDatabase] WARN: Link NOT added, please rescan this device and sync again.
11/14/16 08:47:25 AM [Insteon::BaseInsteon] Link_To_Interface successfully completed for device $garage_iolinc

Still a mystery to me...
Jim