cm11a problems?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

cm11a problems?

Tim Sailer-2
I've seen quite a bit of instability with 2.101. I finally turned on all
the debugging options to see what I could find out. I've also notices that
.101 seems to be sluggiah compared to .100. In the logs I see over and
over:

CM11 send data=AK
CM11 dim=0 header=00000110 hb=0110 cb=0011 bd=0x06,0x63 checksum=0x69
CM11 send: 0663
..
CM11 data=105 hex=69
CM11 ack
.............
CM11 data=85 hex=55
CM11 done
Backlog:
Serial_Item: port= self=X10_Appliance=HASH(0x98874c4) state=off data=XAGAK
interface=cm11
X10: interface=cm11 isfunc=0 save_unit=XAG data=XAG
CM11 send data=AG
CM11 dim=0 header=00000100 hb=0110 cb=1100 bd=0x04,0x6c checksum=0x70
CM11 send: 046c
..
CM11 data=112 hex=70
CM11 ack
.............
CM11 data=85 hex=55
CM11 done
Backlog:
X10: interface=cm11 isfunc=1 save_unit=XAG data=XAK
CM11 send data=AK
CM11 dim=0 header=00000110 hb=0110 cb=0011 bd=0x06,0x63 checksum=0x69
CM11 send: 0663
..
CM11 data=105 hex=69
CM11 ack
...


There is nothing sending this signal. If I switch back to .100, with the
same debigging set, I don;t get the same results.

Any pointers where to look?

Tim





-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365

Reply | Threaded
Open this post in threaded view
|

Re: cm11a problems?

David Norwood-3
> There is nothing sending this signal.

Do you even have a device AG defined in your mht or code files?

David


-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365

Reply | Threaded
Open this post in threaded view
|

Re: cm11a problems?

Tim Sailer-2
On Mon, February 13, 2006 20:06, David Norwood said:
>> There is nothing sending this signal.
>
> Do you even have a device AG defined in your mht or code files?

Yup. It's one of those chime units. Needless to say, it was not activated,
nor was anything trying to turn it off. Control is purely a MH function.
It's not mapped to any remote, etc.

Tim



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365

Reply | Threaded
Open this post in threaded view
|

Re: cm11a problems?

David Norwood-3
> On Mon, February 13, 2006 20:06, David Norwood said:
>>> There is nothing sending this signal.
>>
>> Do you even have a device AG defined in your mht or code files?
>
> Yup. It's one of those chime units. Needless to say, it was not activated,
> nor was anything trying to turn it off. Control is purely a MH function.
> It's not mapped to any remote, etc.

Do the transmissions go away if you disable that item.  If so, what if the
item is defined but all code referencing it is disabled?  I'm guessing the
problem is in X10_Item.pm.  Would you post the mht entry and your code that
deals with the chime?

David



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365

Reply | Threaded
Open this post in threaded view
|

Re: cm11a problems?

Tim Sailer-2
On Mon, February 13, 2006 22:16, David Norwood said:

>> On Mon, February 13, 2006 20:06, David Norwood said:
>>>> There is nothing sending this signal.
>>>
>>> Do you even have a device AG defined in your mht or code files?
>>
>> Yup. It's one of those chime units. Needless to say, it was not
>> activated,
>> nor was anything trying to turn it off. Control is purely a MH function.
>> It's not mapped to any remote, etc.
>
> Do the transmissions go away if you disable that item.  If so, what if the
> item is defined but all code referencing it is disabled?  I'm guessing the
> problem is in X10_Item.pm.  Would you post the mht entry and your code
> that
> deals with the chime?

I'll have to switch over the code a bit later. This only happens running
.101.

X10A,           AG,     chime,  Basement|hidden

$front_door_timer= new Timer;
$back_door_timer= new Timer;
$garage_door_timer= new Timer;

if (state $mode_security eq 'armed')
{
if ((state $front_door eq 'alertmin'))
{
set $front_door_timer 30;
}

if ((state $back_door eq 'alertmin'))
{
set $back_door_timer 30;
}

if (active $front_door_timer)
{
set $chime ON;
speak (address=>'kitchen,bedroom,corrine', mode=>'unmuted', text
=>"Warning! Front
door has opened!");
}

if (expired $front_door_timer)
{
set $chime OFF;
}




-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365

Reply | Threaded
Open this post in threaded view
|

Re: cm11a problems?

David Norwood-3
> On Mon, February 13, 2006 22:16, David Norwood said:
>>> On Mon, February 13, 2006 20:06, David Norwood said:
>>>>> There is nothing sending this signal.
>>>>
>>>> Do you even have a device AG defined in your mht or code files?
>>>
>>> Yup. It's one of those chime units. Needless to say, it was not
>>> activated,
>>> nor was anything trying to turn it off. Control is purely a MH function.
>>> It's not mapped to any remote, etc.
>>
>> Do the transmissions go away if you disable that item.  If so, what if
>> the
>> item is defined but all code referencing it is disabled?  I'm guessing
>> the
>> problem is in X10_Item.pm.  Would you post the mht entry and your code
>> that
>> deals with the chime?
>
> I'll have to switch over the code a bit later. This only happens running
> .101.

I understand this is only in 2.101, but it is probably your mht entry or
code that is triggering the bug.  We need to narrow down where the problem
could be.  If disabling the code stops the problem, try changing this part
of your code:

if (expired $front_door_timer)
{
speak "the door timer expired";
set $chime OFF;
}

then you will know if this code is running when it shouldn't.

David



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=103432&bid=230486&dat=121642
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365